Aerospace Blockset for Xcos  

AB-install

Table of Content

Installation guide

Installation types

Aerospace blockset needs Scilab to work. You should install them first by following instructions from Scilab webpage. It is also necessary to instal CelestLab librabry which is a prerequisite for Aerospace Blockset. Then you can install Aerospace Blockset in multpile ways:

  • Install latest version from ATOMS
  • Manually download ATOMS package for your platform
  • Compile it from the sources

ATOMS installation

This is the simpliest way to install Aerospace Blockset. In order to do that:

  1. Run your Scilab
  2. Go to Applications -> Modue manager - ATOMS
  3. From the module tree navigate to Xcos -> Aerospace Blockset
  4. Click the install button and restart Scilab

Manually download ATOMS package

  1. Go to Aerospace Blockset ATOMS page.
  2. Choose latest version and make sure you have all the prerequisites installed
  3. Download correct package for your platform and unpack it.
  4. Each time you want to use Aerospace Blockset load it from Scilab console by typing: exec(/{aerospace_blockset_path}/loader.sce)

Compile it from the sources

  1. Go to Aerospace Blockset source pagee.
  2. Download packaged source code or clone git repo.
  3. Compile the package by executing exec(/{aerospace_blockset_path}/builder.sce) from the Scilab console.
  4. Each time you want to use Aerospace Blockset load it from Scilab console by typing: exec(/{aerospace_blockset_path}/loader.sce)

Troubleshooting

  1. Aerospace Blockset installs but I get the CelestLab library must be installed before using Aerospace Bloskset error.

This error indicates that CelestLab library is either not installed or not loaded before Aerospace Blockset is started. If you have installed Aerospace blockset manually make sure you load CelestLab first each time. In case you used ATOMS "one click install" it is possible (happens on some systems) that installer configured Scilab in such a way that on startup CelestLab is loaded after Aerospace Blockset. In this case easiset workaround is to uninstall bothj modules and then install them separatelly starting from CelestLab.

Created: 5 years 3 months ago
by Paweł Zagórski